import Foundation
let pattern = #"absoluteText_(\d+)\([^,]+,\s*(.*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"absoluteText_12(A, B, C)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"absoluteText_$1($2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)