re = /absoluteText_(\d+)\([^,]+,\s*(.*?)\)/m
str = 'absoluteText_12(A, B, C)'
subst = 'absoluteText_$1($2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result