use strict;
my $str = 'absoluteText_12(A, B, C)';
my $regex = qr/absoluteText_(\d+)\([^,]+,\s*(.*?)\)/mp;
my $subst = 'absoluteText_$1($2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";