using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A[\s\S]*\S\K\s*\z";
string substitution = @"";
string input = @"Linkin Park.png
Rammstein.png
Metallica.png
Guns N' Roses.png
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}