$re = '/\A[\s\S]*\S\K\s*\z/';
$str = 'Linkin Park.png
Rammstein.png
Metallica.png
Guns N\' Roses.png
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;