re = /\A[\s\S]*\S\K\s*\z/
str = 'Linkin Park.png
Rammstein.png
Metallica.png
Guns N\' Roses.png
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result