import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A[\\s\\S]*\\S\\K\\s*\\z";
final String string = "Linkin Park.png\n"
+ "Rammstein.png\n"
+ "Metallica.png\n"
+ "Guns N' Roses.png\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}