import re
regex = re.compile(r"\A[\s\S]*\S\K\s*\z")
test_str = ("Linkin Park.png\n"
"Rammstein.png\n"
"Metallica.png\n"
"Guns N' Roses.png\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)