const regex = /\A[\s\S]*\S\K\s*\z/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A[\\s\\S]*\\S\\K\\s*\\z', 'g')
const str = `Linkin Park.png
Rammstein.png
Metallica.png
Guns N' Roses.png
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);