import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/(?:www\\.)?(?:youtube(?:-nocookie)?\\.com\\/(?:watch\\?v=|embed\\/)|youtu\\.be\\/)([\\w-]+)(?:\\?.+)?$";
final String string = "Tested in 2024 with various share/embed methods on YouTube video\n\n"
+ "https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE\n"
+ "https://www.youtube.com/watch?v=Lg9vg9c01n4\n"
+ "https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26\n"
+ "https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}