import re
regex = re.compile(r"^https:\/\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\/(?:watch\?v=|embed\/)|youtu\.be\/)([\w-]+)(?:\?.+)?$", flags=re.MULTILINE)
test_str = ("Tested in 2024 with various share/embed methods on YouTube video\n\n"
"https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE\n"
"https://www.youtube.com/watch?v=Lg9vg9c01n4\n"
"https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26\n"
"https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)