re = /^https:\/\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\/(?:watch\?v=|embed\/)|youtu\.be\/)([\w-]+)(?:\?.+)?$/m
str = 'Tested in 2024 with various share/embed methods on YouTube video
https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE
https://www.youtube.com/watch?v=Lg9vg9c01n4
https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result