import Foundation
let pattern = #"^https:\/\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\/(?:watch\?v=|embed\/)|youtu\.be\/)([\w-]+)(?:\?.+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Tested in 2024 with various share/embed methods on YouTube video
https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE
https://www.youtube.com/watch?v=Lg9vg9c01n4
https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)