# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d{3}-\d{3}-\d{4}$/(\1)(\3)(\5)/;t' <<< "XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX"