// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\d{3}-\d{3}-\d{4}$").unwrap();
let string = "XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX";
let substitution = "(\\1)(\\3)(\\5)";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}