using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{3}-\d{3}-\d{4}$";
string substitution = @"(\1)(\3)(\5)";
string input = @"XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}