import Foundation
let pattern = #"^\d{3}-\d{3}-\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1)(\3)(\5)"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}