const regex = /^\d{3}-\d{3}-\d{4}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{3}-\\d{3}-\\d{4}$', '')
const str = `XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX`;
const subst = `(\1)(\3)(\5)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);