re = /^\d{3}-\d{3}-\d{4}$/
str = 'XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX'
subst = '(\\1)(\\3)(\\5)'
result = str.sub(re, subst)
# Print the result of the substitution
puts result