$re = '/^\d{3}-\d{3}-\d{4}$/';
$str = 'XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX';
$subst = "(\1)(\3)(\5)";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;