#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\d{3}-\d{3}-\d{4}$"
Local $sString = "XXX-XXX-XXX" & @CRLF & _
"XX=XXXX^XXX" & @CRLF & _
"XXXXX@XX.XX"
Local $sSubst = "(\1)(\3)(\5)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)