using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)";
string substitution = @"";
string input = @"https://www.instagram.com/Worldfoodprogramme/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}