import re
regex = re.compile(r"(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)", flags=re.MULTILINE)
test_str = "https://www.instagram.com/Worldfoodprogramme/"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)