re = /(?:http[s]?:\/\/)?(?:www\.)?([^\/\n\r]+\.[^\/\n\r]+)/m
str = 'https://www.instagram.com/Worldfoodprogramme/'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result