// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)").unwrap();
let string = "https://www.instagram.com/Worldfoodprogramme/";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}