const regex = new RegExp('(?:http[s]?:\\/\\/)?(?:www\\.)?([^/\\n\\r]+\\.[^/\\n\\r]+)', 'gm')
const str = `https://www.instagram.com/Worldfoodprogramme/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);