package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)`)
var str = `https://www.instagram.com/Worldfoodprogramme/`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}