import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\n*\\w*\\s*)PlayerPoints[^2]\\[(.+?)\\](\\n*\\w*\\s*)";
final String string = " PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}