$re = '/(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)/m';
$str = ' PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;