const regex = /(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\n*\\w*\\s*)PlayerPoints[^2]\\[(.+?)\\](\\n*\\w*\\s*)', 'mg')
const str = ` PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);