import Foundation
let pattern = #"(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)