use strict;
my $str = ' PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] ';
my $regex = qr/(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";