// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)").unwrap();
let string = " PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] ";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}