#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)String\.format\((\".*\")?\, ?(.*)\);"
Local $sString = "String.format("%s foo %s bar", bar(), foo());"
Local $sSubst = "$1.formatted\($2\);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)