re = /String\.format\((\".*\")?\, ?(.*)\);/m
str = 'String.format("%s foo %s bar", bar(), foo());'
subst = '$1.formatted\\($2\\);'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result