using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"String\.format\((\"".*\"")?\, ?(.*)\);";
string substitution = @"$1.formatted\($2\);";
string input = @"String.format(""%s foo %s bar"", bar(), foo());";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}