import Foundation
let pattern = #"String\.format\((\".*\")?\, ?(.*)\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"String.format("%s foo %s bar", bar(), foo());"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.formatted\($2\);"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)