import re
regex = re.compile(r"String\.format\((\".*\")?\, ?(.*)\);", flags=re.MULTILINE)
test_str = "String.format(\"%s foo %s bar\", bar(), foo());"
subst = "$1.formatted\\($2\\);"
result = regex.sub(subst, test_str)
if result:
print(result)