$re = '/String\.format\((\".*\")?\, ?(.*)\);/m';
$str = 'String.format("%s foo %s bar", bar(), foo());';
$subst = "$1.formatted\($2\);";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;