package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)String\.format\((\".*\")?\, ?(.*)\);`)
var str = `String.format("%s foo %s bar", bar(), foo());`
var substitution = "$1.formatted\($2\);"
fmt.Println(re.ReplaceAllString(str, substitution))
}