const regex = /String\.format\((\".*\")?\, ?(.*)\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('String\\.format\\((\\".*\\")?\\, ?(.*)\\);', 'gm')
const str = `String.format("%s foo %s bar", bar(), foo());`;
const subst = `$1.formatted\($2\);`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);