// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)String\.format\((\".*\")?\, ?(.*)\);"#).unwrap();
let string = "String.format(\"%s foo %s bar\", bar(), foo());";
let substitution = "$1.formatted\\($2\\);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}