# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\blog(\w+)\(([^()]+)\)/logGeneral(\2, type = "\L\1")/g;t' <<< "logBug(var1, var2)
logInfo(\"aa\", var2)
logWarning(\"aa\", \"bb\")
logFun(msg1 = \"aa\", msg2 = \"bb\")
logFun(msg1 = var1, msg2 = \"bb\")"