const regex = /\blog(\w+)\(([^()]+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\blog(\\w+)\\(([^()]+)\\)', 'g')
const str = `logBug(var1, var2)
logInfo("aa", var2)
logWarning("aa", "bb")
logFun(msg1 = "aa", msg2 = "bb")
logFun(msg1 = var1, msg2 = "bb")`;
const subst = `logGeneral(\2, type = "\L\1")`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);