# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\blog(\w+)\(([^()]+)\)"
test_str = ("logBug(var1, var2)\n"
"logInfo(\"aa\", var2)\n"
"logWarning(\"aa\", \"bb\")\n"
"logFun(msg1 = \"aa\", msg2 = \"bb\")\n"
"logFun(msg1 = var1, msg2 = \"bb\")")
subst = "logGeneral(\\2, type = \"\\L\\1\")"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.