// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\blog(\w+)\(([^()]+)\)").unwrap();
let string = "logBug(var1, var2)
logInfo(\"aa\", var2)
logWarning(\"aa\", \"bb\")
logFun(msg1 = \"aa\", msg2 = \"bb\")
logFun(msg1 = var1, msg2 = \"bb\")";
let substitution = "logGeneral(\\2, type = \"\\L\\1\")";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}