use strict;
my $str = 'logBug(var1, var2)
logInfo("aa", var2)
logWarning("aa", "bb")
logFun(msg1 = "aa", msg2 = "bb")
logFun(msg1 = var1, msg2 = "bb")';
my $regex = qr/\blog(\w+)\(([^()]+)\)/p;
my $subst = 'logGeneral(\\2, type = "\\L\\1")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";