package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\blog(\w+)\(([^()]+)\)`)
var str = `logBug(var1, var2)
logInfo("aa", var2)
logWarning("aa", "bb")
logFun(msg1 = "aa", msg2 = "bb")
logFun(msg1 = var1, msg2 = "bb")`
var substitution = "logGeneral(\2, type = "\L\1")"
fmt.Println(re.ReplaceAllString(str, substitution))
}