$re = '/\blog(\w+)\(([^()]+)\)/';
$str = 'logBug(var1, var2)
logInfo("aa", var2)
logWarning("aa", "bb")
logFun(msg1 = "aa", msg2 = "bb")
logFun(msg1 = var1, msg2 = "bb")';
$subst = "logGeneral(\2, type = \"\L\1\")";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;