import Foundation
let pattern = #"\blog(\w+)\(([^()]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
logBug(var1, var2)
logInfo("aa", var2)
logWarning("aa", "bb")
logFun(msg1 = "aa", msg2 = "bb")
logFun(msg1 = var1, msg2 = "bb")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"logGeneral(\2, type = "\L\1")"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)